gmm-5.1.ebuild 569 B

1234567891011121314151617181920212223
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic
  5. DESCRIPTION="Generic C++ template library for sparse, dense and skyline matrices"
  6. SRC_URI="http://download.gna.org/getfem/stable/${P}.tar.gz"
  7. HOMEPAGE="http://www-gmm.insa-toulouse.fr/getfem/"
  8. LICENSE="|| ( LGPL-3 LGPL-3-with-linking-exception )"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. src_configure() {
  13. # required for tests, #612294
  14. append-cxxflags -std=c++14
  15. default
  16. }