gwnum-277.ebuild 786 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="George Woltman's GWNUM library"
  5. HOMEPAGE="http://www.mersenne.org/freesoft/"
  6. # Sourcecode split out from prime95, we don't need the full lib
  7. SRC_URI="http://gentooexperimental.org/~patrick/${P}.tar.bz2"
  8. inherit eutils
  9. LICENSE="gwnum BSD GPL-2+"
  10. SLOT="0"
  11. # Need to test if it actually compiles on x86
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. RESTRICT="bindist" #465566
  15. DEPEND=""
  16. RDEPEND="${DEPEND}"
  17. src_compile() {
  18. # makefile doesn't return zero? || die fails :(
  19. use amd64 && emake -f make64
  20. use x86 && emake
  21. }
  22. src_install() {
  23. mkdir "${D}/usr/lib" -p
  24. cp gwnum.a gwnum.lib "${D}/usr/lib" || die
  25. mkdir "${D}/usr/include" -p
  26. cp *.h "${D}/usr/include" || die
  27. }