lybniz-1.3.2-r1.ebuild 558 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="A function plotter program written in PyGTK"
  7. HOMEPAGE="http://lybniz2.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/lybniz2/${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. DEPEND="dev-python/pygtk:2[${PYTHON_USEDEP}]"
  14. RDEPEND="${DEPEND}"
  15. src_prepare() {
  16. sed -i \
  17. -e 's/Education;/Education;Math;/' \
  18. ${PN}.desktop || die
  19. distutils-r1_src_prepare
  20. }