nestedsums-1.4.12-r2.ebuild 844 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
  5. HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~stefanw/nestedsums/"
  6. IUSE="doc"
  7. SRC_URI="http://wwwthep.physik.uni-mainz.de/~stefanw/download/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. RDEPEND=">=sci-mathematics/ginac-1.5 <sci-mathematics/ginac-1.7"
  12. DEPEND="${RDEPEND}
  13. doc? ( app-doc/doxygen )"
  14. src_compile() {
  15. emake || die "emake failed"
  16. if use doc; then
  17. doxygen Doxyfile || die "generating documentation failed"
  18. fi
  19. }
  20. src_install() {
  21. emake DESTDIR="${D}" install
  22. rm -f "${D}"usr/lib/*.la
  23. dodoc AUTHORS ChangeLog
  24. if use doc; then
  25. dohtml reference/html/* || die "installing documentation failed"
  26. fi
  27. }