prover9-2009.11a.ebuild 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs versionator
  5. MY_PN="LADR"
  6. typeset -u MY_PV
  7. MY_PV=$(replace_all_version_separators '-')
  8. MY_P="${MY_PN}-${MY_PV}"
  9. DESCRIPTION="Automated theorem prover for first-order and equational logic"
  10. HOMEPAGE="http://www.cs.unm.edu/~mccune/mace4/"
  11. SRC_URI="
  12. http://www.cs.unm.edu/~mccune/mace4/download/${MY_P}.tar.gz
  13. https://dev.gentoo.org/~jlec/distfiles/${MY_PN}-2009-11A-makefile.patch.xz"
  14. SLOT="0"
  15. KEYWORDS="~amd64 ~x86"
  16. LICENSE="GPL-2"
  17. IUSE="examples"
  18. PATCHES=(
  19. "${WORKDIR}"/${MY_PN}-2009-11A-makefile.patch
  20. "${FILESDIR}"/${MY_PN}-2009-11A-manpages.patch
  21. )
  22. S="${WORKDIR}/${MY_P}/"
  23. src_prepare() {
  24. MAKEOPTS+=" -j1"
  25. epatch "${PATCHES[@]}"
  26. sed \
  27. -e "/^CC =/s:gcc:$(tc-getCC):g" \
  28. -i */Makefile || die
  29. }
  30. src_compile() {
  31. emake all
  32. }
  33. src_install () {
  34. dobin \
  35. bin/attack \
  36. bin/autosketches4 \
  37. bin/clausefilter \
  38. bin/clausetester \
  39. bin/complex \
  40. bin/directproof \
  41. bin/dprofiles \
  42. bin/fof-prover9 \
  43. bin/gen_trc_defs \
  44. bin/get_givens \
  45. bin/get_interps \
  46. bin/get_kept \
  47. bin/gvizify \
  48. bin/idfilter \
  49. bin/interpfilter \
  50. bin/interpformat \
  51. bin/isofilter \
  52. bin/isofilter0 \
  53. bin/isofilter2 \
  54. bin/ladr_to_tptp \
  55. bin/latfilter \
  56. bin/looper \
  57. bin/mace4 \
  58. bin/miniscope \
  59. bin/mirror-flip \
  60. bin/newauto \
  61. bin/newsax \
  62. bin/olfilter \
  63. bin/perm3 \
  64. bin/proof3fo.xsl \
  65. bin/prooftrans \
  66. bin/prover9 \
  67. bin/renamer \
  68. bin/rewriter \
  69. bin/sigtest \
  70. bin/test_clause_eval \
  71. bin/test_complex \
  72. bin/tptp_to_ladr \
  73. bin/unfast \
  74. bin/upper-covers
  75. doman \
  76. manpages/interpformat.1 \
  77. manpages/isofilter.1 \
  78. manpages/prooftrans.1 \
  79. manpages/mace4.1 \
  80. manpages/prover9.1 \
  81. manpages/clausefilter.1 \
  82. manpages/clausetester.1 \
  83. manpages/interpfilter.1 \
  84. manpages/rewriter.1 \
  85. manpages/prover9-apps.1
  86. dohtml ladr/index.html.master ladr/html/*
  87. insinto /usr/$(get_libdir)
  88. dolib.so ladr/.libs/libladr.so.4.0.0
  89. dosym libladr.so.4.0.0 /usr/$(get_libdir)/libladr.so.4
  90. dosym libladr.so.4.0.0 /usr/$(get_libdir)/libladr.so
  91. dodir /usr/include/ladr
  92. insinto /usr/include/ladr
  93. doins ladr/*.h
  94. if use examples; then
  95. insinto /usr/share/${PN}/examples
  96. doins prover9.examples/*
  97. # The prover9-mace4 script is installed as an example script
  98. # to avoid confusion with the GUI sci-mathematics/p9m4 prover9mace4.py
  99. insinto /usr/share/${PN}/scripts
  100. doins bin/prover9-mace4
  101. fi
  102. }