relational-2.5.ebuild 875 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python3_{4,5} )
  5. inherit python-single-r1
  6. DESCRIPTION="Educational tool for relational algebra"
  7. HOMEPAGE="http://ltworf.github.io/relational/"
  8. SRC_URI="https://github.com/ltworf/${PN}/releases/download/${PV}/${PN}_${PV}.orig.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. DEPEND="
  14. ${PYTHON_DEPS}
  15. dev-python/PyQt5[gui,webkit,widgets,${PYTHON_USEDEP}]
  16. "
  17. RDEPEND="${DEPEND}"
  18. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  19. S=${WORKDIR}/${PN}
  20. src_prepare() {
  21. default
  22. sed -i -e '/^Terminal=/ s/0/false/' \
  23. -e '/^Keywords=/ s/$/;/' \
  24. relational.desktop || die
  25. }
  26. src_install() {
  27. emake -j1 DESTDIR="${ED}" install-{relational-cli,python3-relational,relational}
  28. python_optimize
  29. dodoc CHANGELOG complexity CREDITS README.md
  30. }