rkward-0.6.1.ebuild 763 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. KDE_DOC_DIRS="doc"
  5. KDE_HANDBOOK="optional"
  6. KDE_LINGUAS="ca cs da de el es fr it lt pl tr zh_CN"
  7. inherit kde4-base
  8. DESCRIPTION="IDE for the R-project"
  9. HOMEPAGE="http://rkward.sourceforge.net/"
  10. SRC_URI="mirror://sourceforge/rkward/${P}.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="4"
  13. KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
  14. IUSE="debug"
  15. DEPEND="
  16. dev-lang/R
  17. $(add_kdeapps_dep katepart)"
  18. RDEPEND="${DEPEND}"
  19. src_configure() {
  20. # to have it compatible with R which had a bad R_HOME
  21. unset R_HOME
  22. kde4-base_src_configure
  23. }
  24. src_install() {
  25. kde4-base_src_install
  26. # avoid file collision with kate
  27. rm "${ED}"/usr/share/apps/katepart/syntax/r.xml || die
  28. }