spin-6.2.5.ebuild 922 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs versionator
  5. MY_PV=$(replace_all_version_separators '')
  6. MY_P="${PN}${MY_PV}"
  7. DESCRIPTION="Tool for formal verification of distributed software systems"
  8. HOMEPAGE="http://spinroot.com/"
  9. SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz"
  10. LICENSE="|| ( spin-commercial spin-educational )"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="graphviz tk"
  14. DEPEND="sys-devel/bison"
  15. RDEPEND="sys-devel/gcc
  16. sys-process/time
  17. tk? (
  18. dev-lang/tk
  19. graphviz? ( media-gfx/graphviz )
  20. )"
  21. S="${WORKDIR}/Spin/Src${PV}"
  22. src_prepare() {
  23. epatch "${FILESDIR}/${PN}-6.2.5-makefile.patch"
  24. }
  25. src_compile() {
  26. tc-export CC
  27. default
  28. }
  29. src_install() {
  30. dobin spin
  31. doman ../Man/spin.1
  32. dodoc ../Doc/*
  33. if use tk; then
  34. newbin "${WORKDIR}/Spin/iSpin/ispin.tcl" ispin
  35. make_desktop_entry ispin
  36. fi
  37. }