xmds-2.2.2.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="XMDS - The eXtensible Multi-Dimensional Simulator"
  7. HOMEPAGE="http://www.xmds.org"
  8. SRC_URI="mirror://sourceforge/xmds/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="doc examples mpi"
  13. DEPEND="dev-python/cheetah[${PYTHON_USEDEP}]"
  14. RDEPEND=">=sci-libs/fftw-3.3.1:3.0=[mpi?]
  15. mpi? ( virtual/mpi )
  16. dev-python/numpy[${PYTHON_USEDEP}]
  17. dev-python/pyparsing[${PYTHON_USEDEP}]
  18. dev-python/lxml[${PYTHON_USEDEP}]
  19. dev-python/mpmath[${PYTHON_USEDEP}]
  20. dev-python/h5py[${PYTHON_USEDEP}]
  21. sci-libs/atlas
  22. sci-libs/hdf5
  23. sci-libs/gsl"
  24. #virtual/cblas
  25. python_install_all() {
  26. use doc && HTML_DOCS+=( documentation/. )
  27. if use examples; then
  28. docompress -x "/usr/share/doc/${PF}/examples"
  29. dodoc -r examples
  30. fi
  31. distutils-r1_python_install_all
  32. }
  33. pkg_postinst() {
  34. elog "Configure XMDS2 by typing"
  35. elog "xmds2 --reconfigure"
  36. elog "See http://www.xmds.org/installation.html for further informations"
  37. }