h5utils-1.12.1-r2.ebuild 782 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=true
  5. inherit autotools-utils
  6. DESCRIPTION="Utilities for visualization and conversion of HDF5 files"
  7. HOMEPAGE="http://ab-initio.mit.edu/h5utils/"
  8. SRC_URI="http://ab-initio.mit.edu/h5utils/${P}.tar.gz"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux"
  12. IUSE="hdf octave"
  13. DEPEND="
  14. media-libs/libpng:0=
  15. sci-libs/hdf5:0=
  16. sys-libs/zlib:0=
  17. hdf? (
  18. sci-libs/hdf:0=
  19. virtual/jpeg:0
  20. )"
  21. RDEPEND="${DEPEND}"
  22. PATCHES=(
  23. "${FILESDIR}"/${P}-automagic.patch
  24. "${FILESDIR}"/${P}-png15.patch
  25. )
  26. src_configure() {
  27. local myeconfargs=(
  28. --without-v5d
  29. $(use_with octave)
  30. $(use_with hdf)
  31. )
  32. autotools-utils_src_configure
  33. }