harminv-1.3.1-r1.ebuild 753 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools toolchain-funcs
  5. DESCRIPTION="Extraction of complex frequencies and amplitudes from time series"
  6. HOMEPAGE="http://ab-initio.mit.edu/harminv/"
  7. SRC_URI="http://ab-initio.mit.edu/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="static-libs"
  12. RDEPEND="virtual/lapack"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. PATCHES=( "${FILESDIR}"/${P}-configure.ac.patch )
  16. src_prepare() {
  17. default
  18. eautoreconf
  19. }
  20. src_configure() {
  21. econf \
  22. $(use_enable static-libs static) \
  23. --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
  24. --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
  25. }