yoda-1.4.0.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_IN_SOURCE_BUILD=1
  5. PYTHON_COMPAT=( python2_7 )
  6. inherit python-single-r1 autotools-utils bash-completion-r1
  7. MYP=YODA-${PV}
  8. DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
  9. HOMEPAGE="http://yoda.hepforge.org/"
  10. SRC_URI="http://www.hepforge.org/archive/${PN}/${MYP}.tar.bz2"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  14. IUSE="c++11 python root static-libs"
  15. RDEPEND="
  16. dev-libs/boost:0=
  17. python? ( ${PYTHON_DEPS} )
  18. root? ( sci-physics/root:0=[python=,${PYTHON_USEDEP}] )"
  19. DEPEND="${RDEPEND}
  20. python? ( dev-python/cython[${PYTHON_USEDEP}] )"
  21. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  22. S="${WORKDIR}/${MYP}"
  23. pkg_setup() {
  24. use python && python-single-r1_pkg_setup
  25. }
  26. src_configure() {
  27. local myeconfargs=(
  28. $(use_enable c++11 stdcxx11)
  29. $(use_enable python pyext)
  30. $(use_enable root)
  31. )
  32. autotools-utils_src_configure
  33. }
  34. src_install() {
  35. autotools-utils_src_install
  36. newbashcomp "${ED}"/usr/share/YODA/yoda-completion yoda
  37. }