opendx-4.4.4-r5.ebuild 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. MYP=dx-${PV}
  5. inherit eutils flag-o-matic autotools multilib
  6. DESCRIPTION="3D data visualization tool"
  7. HOMEPAGE="http://www.opendx.org/"
  8. SRC_URI="http://opendx.sdsc.edu/source/${MYP}.tar.gz"
  9. LICENSE="IBM"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
  12. IUSE="hdf cdf netcdf tiff imagemagick szip smp"
  13. RDEPEND="x11-libs/libXmu
  14. x11-libs/libXi
  15. x11-libs/libXp
  16. x11-libs/libXpm
  17. >=x11-libs/motif-2.3:0
  18. virtual/opengl
  19. virtual/glu
  20. szip? ( virtual/szip )
  21. hdf? ( sci-libs/hdf )
  22. cdf? ( sci-libs/cdf )
  23. netcdf? ( sci-libs/netcdf )
  24. tiff? ( media-libs/tiff )
  25. imagemagick? ( virtual/imagemagick-tools )"
  26. DEPEND="${RDEPEND}
  27. virtual/pkgconfig"
  28. S="${WORKDIR}/${MYP}"
  29. src_prepare() {
  30. epatch "${FILESDIR}/${PN}-4.3.2-sys.h.patch"
  31. epatch "${FILESDIR}/${P}-installpaths.patch"
  32. epatch "${FILESDIR}/${P}-xdg.patch"
  33. epatch "${FILESDIR}/${P}-gcc43.patch"
  34. epatch "${FILESDIR}/${P}-dx-errno.patch"
  35. epatch "${FILESDIR}/${P}-libtool.patch"
  36. epatch "${FILESDIR}/${P}-concurrent-make-fix.patch"
  37. epatch "${FILESDIR}/${P}-open.patch"
  38. epatch "${FILESDIR}/${P}-szip.patch"
  39. epatch "${FILESDIR}/${P}-null.patch"
  40. epatch "${FILESDIR}/${P}-magick.patch"
  41. eautoreconf
  42. }
  43. src_configure() {
  44. # check flag filtering
  45. # with gcc 3.3.2 I had an infinite loop on src/exec/libdx/zclipQ.c
  46. append-flags -fno-strength-reduce
  47. # (#82672)
  48. filter-flags -finline-functions
  49. replace-flags -O3 -O2
  50. # opendx uses this variable
  51. unset ARCH
  52. # javadx is currently broken. we may try to fix it someday.
  53. econf \
  54. --libdir="${EPREFIX}"/usr/$(get_libdir) \
  55. --with-x \
  56. --without-javadx \
  57. $(use_with szip szlib) \
  58. $(use_with cdf) \
  59. $(use_with netcdf) \
  60. $(use_with hdf) \
  61. $(use_with tiff) \
  62. $(use_with imagemagick magick) \
  63. $(use_enable smp smp-linux)
  64. }
  65. src_install() {
  66. default
  67. newicon src/uipp/ui/icon50.xpm ${PN}.xpm
  68. make_desktop_entry dx "Open Data Explorer"
  69. }