opendx-4.4.4-r6.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MYP=dx-${PV}
  5. inherit autotools eutils flag-o-matic
  6. DESCRIPTION="3D data visualization tool"
  7. HOMEPAGE="http://www.opendx.org/"
  8. SRC_URI="http://opendx.sdsc.edu/source/${MYP}.tar.gz
  9. https://dev.gentoo.org/~soap/distfiles/${PN}-4.4.4_p20160917-fix-c++14.patch.bz2"
  10. LICENSE="IBM"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  13. IUSE="hdf cdf netcdf tiff imagemagick szip smp"
  14. RDEPEND="x11-libs/libXmu
  15. x11-libs/libXi
  16. x11-libs/libXp
  17. x11-libs/libXpm
  18. >=x11-libs/motif-2.3:0
  19. virtual/opengl
  20. virtual/glu
  21. szip? ( virtual/szip )
  22. hdf? ( sci-libs/hdf )
  23. cdf? ( sci-libs/cdf )
  24. netcdf? ( sci-libs/netcdf )
  25. tiff? ( media-libs/tiff:0 )
  26. imagemagick? ( virtual/imagemagick-tools )"
  27. DEPEND="${RDEPEND}
  28. virtual/pkgconfig"
  29. S="${WORKDIR}/${MYP}"
  30. PATCHES=(
  31. "${FILESDIR}/${PN}-4.3.2-sys.h.patch"
  32. "${FILESDIR}/${P}-installpaths.patch"
  33. "${FILESDIR}/${P}-xdg.patch"
  34. "${FILESDIR}/${P}-gcc43.patch"
  35. "${FILESDIR}/${P}-dx-errno.patch"
  36. "${FILESDIR}/${P}-libtool.patch"
  37. "${FILESDIR}/${P}-concurrent-make-fix.patch"
  38. "${FILESDIR}/${P}-open.patch"
  39. "${FILESDIR}/${P}-szip.patch"
  40. "${FILESDIR}/${P}-null.patch"
  41. "${WORKDIR}/${PN}-4.4.4_p20160917-fix-c++14.patch"
  42. )
  43. src_prepare() {
  44. default
  45. eautoreconf
  46. }
  47. src_configure() {
  48. # check flag filtering
  49. # with gcc 3.3.2 I had an infinite loop on src/exec/libdx/zclipQ.c
  50. append-flags -fno-strength-reduce
  51. # (#82672)
  52. filter-flags -finline-functions
  53. replace-flags -O3 -O2
  54. # opendx uses this variable
  55. unset ARCH
  56. # javadx is currently broken. we may try to fix it someday.
  57. econf \
  58. --with-x \
  59. --without-javadx \
  60. $(use_with szip szlib) \
  61. $(use_with cdf) \
  62. $(use_with netcdf) \
  63. $(use_with hdf) \
  64. $(use_with tiff) \
  65. $(use_with imagemagick magick) \
  66. $(use_enable smp smp-linux)
  67. }
  68. src_install() {
  69. default
  70. newicon src/uipp/ui/icon50.xpm ${PN}.xpm
  71. make_desktop_entry dx "Open Data Explorer"
  72. }