apparmor-profiles-2.10.1.ebuild 615 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit versionator
  5. DESCRIPTION="A collection of profiles for the AppArmor application security system"
  6. HOMEPAGE="http://apparmor.net/"
  7. SRC_URI="https://launchpad.net/apparmor/$(get_version_component_range 1-2)/${PV}/+download/apparmor-${PV}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="minimal"
  12. RESTRICT="test"
  13. S=${WORKDIR}/apparmor-${PV}/profiles
  14. src_install() {
  15. if use minimal ; then
  16. insinto /etc/apparmor.d
  17. doins -r apparmor.d/{abstractions,tunables}
  18. else
  19. default
  20. fi
  21. }