ack-2.18.ebuild 793 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DIST_AUTHOR=PETDANCE
  5. inherit perl-module
  6. DESCRIPTION="ack is a tool like grep, optimized for programmers"
  7. HOMEPAGE="http://betterthangrep.com/ ${HOMEPAGE}"
  8. LICENSE="Artistic-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86 ~amd64-linux ~x86-linux ~x86-macos"
  11. IUSE="test"
  12. RDEPEND=">=dev-perl/File-Next-1.100.0"
  13. DEPEND="${RDEPEND}
  14. test? ( dev-perl/IO-Tty )"
  15. SRC_TEST=do
  16. PATCHES=( "${FILESDIR}"/${PN}-2.14-gentoo.patch )
  17. src_test() {
  18. # Tests fail when run in parallel and if dev-perl/IO-Tty is installed
  19. # which enables interactive tests that need to read from stdin. If IO-Tty
  20. # is not installed the related tests are skipped.
  21. MAKEOPTS+=" -j1" perl-module_src_test
  22. }