agedu-20160920.ebuild 838 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit autotools eutils
  5. # agedu-20151213.59b0ed3.ebuild is not a legitimate name
  6. # so we'll drop versionator and just set MY_P manually.
  7. MY_P="${PN}"-20160920.853cea9
  8. DESCRIPTION="A utility for tracking down wasted disk space"
  9. HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/agedu/"
  10. SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${MY_P}.tar.gz -> ${MY_P}.tar.gz"
  11. S="${WORKDIR}/${MY_P}"
  12. LICENSE="MIT"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~x86"
  15. IUSE="doc ipv6"
  16. DEPEND="doc? ( app-doc/halibut )"
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
  20. eapply_user
  21. eautoreconf
  22. }
  23. src_configure() {
  24. econf --enable-ipv4 \
  25. $(use_enable doc halibut) \
  26. $(use_enable ipv6)
  27. }