chname-1.0-r2.ebuild 651 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Run a command with a new system hostname"
  6. HOMEPAGE="https://github.com/marineam/chname"
  7. SRC_URI="https://github.com/marineam/${PN}/archive/v1.0.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND=">=sys-kernel/linux-headers-2.6.16"
  13. RDEPEND=""
  14. src_compile() {
  15. emake CC=$(tc-getCC) CFLAGS="${CFLAGS} ${LDFLAGS}" "${PN}"
  16. }
  17. src_install() {
  18. dobin "${PN}"
  19. doman "${PN}.1"
  20. }
  21. pkg_postinst() {
  22. elog "Note: chname requires a or later kernel with CONFIG_UTS_NS=y."
  23. }