chname-1.1.ebuild 583 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit toolchain-funcs
  5. DESCRIPTION="Run a command with a new system hostname"
  6. HOMEPAGE="https://github.com/marineam/chname"
  7. SRC_URI="https://github.com/marineam/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND=">=sys-kernel/linux-headers-2.6.16"
  13. RDEPEND=""
  14. PATCHES=(
  15. "${FILESDIR}"/${P}-flags.patch
  16. )
  17. src_configure() {
  18. tc-export CC
  19. }
  20. src_install() {
  21. dobin "${PN}"
  22. doman "${PN}.1"
  23. dodoc README*
  24. }