cinit-0.2.1.ebuild 840 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs
  5. DESCRIPTION="a fast, small and simple init with support for profiles"
  6. HOMEPAGE="http://linux.schottelius.org/cinit/"
  7. SRC_URI="http://linux.schottelius.org/${PN}/archives/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~hppa ~ppc ~x86"
  11. IUSE="doc"
  12. src_prepare() {
  13. sed -i "/contrib+tools/d" Makefile || die
  14. sed -i "/^STRIP/s/strip.*/true/" Makefile.include || die
  15. }
  16. src_compile() {
  17. emake \
  18. CC="$(tc-getCC)" \
  19. LD="$(tc-getCC)" \
  20. CFLAGS="${CFLAGS} -I." \
  21. LDFLAGS="${LDFLAGS}" \
  22. STRIP=/bin/true \
  23. all
  24. }
  25. src_install() {
  26. emake LD=$(tc-getCC) DESTDIR="${D}" install
  27. rm -f "${D}"/sbin/{init,shutdown,reboot}
  28. dodoc Changelog CHANGES CREDITS README TODO
  29. use doc && dodoc -r doc
  30. }