cobalt-panel-utils-1.0.2.ebuild 963 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit eutils
  5. DESCRIPTION="LCD and LED panel utilities for the Sun Cobalts"
  6. HOMEPAGE="http://gentoo.404ster.com/"
  7. SRC_URI="ftp://www.404ster.com/pub/gentoo-stuff/ebuilds/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~mips x86"
  11. IUSE="static"
  12. RDEPEND="sys-devel/gettext"
  13. DEPEND="${DEPEND}
  14. sys-devel/autoconf"
  15. src_configure() {
  16. sed -i \
  17. -e"/^COPTS/s:= := ${CFLAGS} :" \
  18. -e"/^LDFLAGS/s:= := ${LDFLAGS} :"\
  19. Makefile || die "sed failed"
  20. }
  21. src_compile() {
  22. if use static; then
  23. einfo "Building as static executables"
  24. export STATIC="-static"
  25. fi
  26. emake || die
  27. }
  28. src_install() {
  29. into /
  30. dosbin "${S}"/lcd-flash "${S}"/lcd-getip "${S}"/lcd-swrite \
  31. "${S}"/lcd-write "${S}"/lcd-yesno "${S}"/lcd-setcursor "${S}"/iflink
  32. "${S}"/iflinkstatus "${S}"/readbutton || die "dosbin failed"
  33. dodoc doc/README* doc/CREDITS
  34. doman doc/man/*.1
  35. }