cpint-2.5.3.ebuild 650 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit linux-info eutils
  5. MY_PV=${PV//./}
  6. DESCRIPTION="Linux/390 Interface to z/VM's Control Program"
  7. HOMEPAGE="http://linuxvm.org/Patches/index.html"
  8. SRC_URI="http://linuxvm.org/Patches/s390/${PN}${MY_PV}.tgz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="s390"
  12. IUSE=""
  13. src_prepare() {
  14. epatch "${FILESDIR}"/${P}-build.patch
  15. epatch "${FILESDIR}"/${P}-prototypes.patch
  16. epatch "${FILESDIR}"/${P}-kernel.patch
  17. # the makefile uses this variable
  18. export KERNEL_DIR
  19. }
  20. src_install() {
  21. emake install prefix="${D}"
  22. dodoc ChangeLog HOW-TO
  23. }