cpuid-20130610.ebuild 618 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Utility to get detailed information about the CPU(s) using the
  6. CPUID instruction"
  7. HOMEPAGE="http://www.etallen.com/cpuid.html"
  8. SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
  9. KEYWORDS="amd64 x86"
  10. SLOT="0"
  11. LICENSE="GPL-2"
  12. IUSE=""
  13. src_prepare() {
  14. epatch "${FILESDIR}"/${PN}-20110305-Makefile.patch
  15. epatch "${FILESDIR}"/${PN}-20110305-fPIC.patch #376245
  16. }
  17. src_compile() {
  18. tc-export CC
  19. emake
  20. }
  21. src_install() {
  22. emake BUILDROOT="${D}" install
  23. }