dchroot-0.12.1.ebuild 755 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit toolchain-funcs
  5. DESCRIPTION="Utility for managing chroots for non-root users"
  6. HOMEPAGE="http://packages.debian.org/unstable/admin/dchroot"
  7. SRC_URI="mirror://debian/pool/main/d/dchroot/dchroot_${PV}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND="sys-apps/help2man"
  13. RDEPEND="!dev-util/schroot[dchroot]"
  14. src_prepare() {
  15. sed -i \
  16. -e '/^all:/s:$: docs:' \
  17. -e '/^CFLAGS/s:-O2:@CFLAGS@:' \
  18. -e '/@CFLAGS@/ s:@CFLAGS@:@CFLAGS@ @LDFLAGS@:' \
  19. Makefile.in || die "sed failed"
  20. }
  21. src_compile() {
  22. emake CC="$(tc-getCC)" || die
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" install || die
  26. dodoc README TODO
  27. }