dnotify-0.18.0.ebuild 650 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit eutils
  5. DESCRIPTION="Execute a command when the contents of a directory change"
  6. HOMEPAGE="http://directory.fsf.org/project/dnotify/"
  7. SRC_URI="mirror://gentoo/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~mips ppc -sparc x86"
  11. IUSE="nls"
  12. RDEPEND=""
  13. DEPEND="nls? ( sys-devel/gettext )"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-nls.patch \
  16. "${FILESDIR}"/${P}-glibc-212.patch
  17. }
  18. src_configure() {
  19. econf \
  20. $(use_enable nls)
  21. }
  22. src_install() {
  23. emake DESTDIR="${D}" install || die
  24. dodoc AUTHORS TODO NEWS README
  25. }