dstat-0.7.3.ebuild 683 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-r1
  6. DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
  7. HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
  8. SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
  12. IUSE="wifi doc examples"
  13. RDEPEND="wifi? ( net-wireless/python-wifi )"
  14. DEPEND=""
  15. src_install() {
  16. default
  17. if use examples; then
  18. dodoc examples/{mstat,read}.py
  19. fi
  20. if use doc; then
  21. dodoc docs/*.html
  22. fi
  23. }