elfix-9999.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. if [[ ${PV} == "9999" ]] ; then
  6. EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
  7. inherit git-2
  8. else
  9. SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
  11. fi
  12. DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
  13. HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
  14. https://dev.gentoo.org/~blueness/elfix/"
  15. LICENSE="GPL-3"
  16. SLOT="0"
  17. IUSE="+ptpax +xtpax"
  18. REQUIRED_USE="|| ( ptpax xtpax )"
  19. # These only work with a properly configured PaX kernel
  20. RESTRICT="test"
  21. DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
  22. ptpax? ( dev-libs/elfutils )
  23. xtpax? ( sys-apps/attr )"
  24. RDEPEND="${DEPEND}"
  25. src_prepare() {
  26. [[ ${PV} == "9999" ]] && ./autogen.sh
  27. }
  28. src_configure() {
  29. rm -f "${S}/scripts/setup.py"
  30. econf --disable-tests \
  31. $(use_enable ptpax) \
  32. $(use_enable xtpax)
  33. }
  34. src_install() {
  35. emake DESTDIR="${D}" install
  36. dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
  37. }