findutils-4.5.18.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. inherit eutils flag-o-matic toolchain-funcs python-any-r1
  6. DESCRIPTION="GNU utilities for finding files"
  7. HOMEPAGE="https://www.gnu.org/software/findutils/"
  8. SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-3+"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  12. IUSE="debug nls selinux static test"
  13. RDEPEND="selinux? ( sys-libs/libselinux )
  14. nls? ( virtual/libintl )"
  15. DEPEND="${RDEPEND}
  16. test? ( ${PYTHON_DEPS} )
  17. nls? ( sys-devel/gettext )"
  18. pkg_setup() {
  19. use test && python-any-r1_pkg_setup
  20. }
  21. src_prepare() {
  22. # Don't build or install locate because it conflicts with slocate,
  23. # which is a secure version of locate. See bug 18729
  24. sed -i '/^SUBDIRS/s/locate//' Makefile.in
  25. }
  26. src_configure() {
  27. use static && append-ldflags -static
  28. program_prefix=$(usex userland_GNU '' g)
  29. econf \
  30. --with-packager="Gentoo" \
  31. --with-packager-version="${PVR}" \
  32. --with-packager-bug-reports="https://bugs.gentoo.org/" \
  33. --program-prefix=${program_prefix} \
  34. $(use_enable debug) \
  35. $(use_enable nls) \
  36. $(use_with selinux) \
  37. --libexecdir='$(libdir)'/find
  38. }
  39. src_compile() {
  40. # We don't build locate, but the docs want a file in there.
  41. emake -C locate dblocation.texi
  42. default
  43. }