findutils-4.6.0-r1.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. inherit eutils flag-o-matic toolchain-funcs python-any-r1
  6. DESCRIPTION="GNU utilities for finding files"
  7. HOMEPAGE="https://www.gnu.org/software/findutils/"
  8. SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-3+"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  12. IUSE="nls selinux static test"
  13. RDEPEND="selinux? ( sys-libs/libselinux )
  14. nls? ( virtual/libintl )"
  15. DEPEND="${RDEPEND}
  16. test? ( ${PYTHON_DEPS} )
  17. nls? ( sys-devel/gettext )"
  18. pkg_setup() {
  19. use test && python-any-r1_pkg_setup
  20. }
  21. src_prepare() {
  22. # Don't build or install locate because it conflicts with slocate,
  23. # which is a secure version of locate. See bug 18729
  24. sed -i '/^SUBDIRS/s/locate//' Makefile.in
  25. # Newer C libraries omit this include from sys/types.h.
  26. # https://lists.gnu.org/archive/html/bug-gnulib/2016-03/msg00018.html
  27. sed -i \
  28. '/include.*config.h/a#ifdef MAJOR_IN_SYSMACROS\n#include <sys/sysmacros.h>\n#endif\n' \
  29. gl/lib/mountlist.c || die
  30. epatch "${FILESDIR}"/${P}-gnulib-mb.patch #576818
  31. epatch "${FILESDIR}"/${P}-gnulib-S_MAGIC_NFS.patch #580032
  32. }
  33. src_configure() {
  34. use static && append-ldflags -static
  35. program_prefix=$(usex userland_GNU '' g)
  36. econf \
  37. --with-packager="Gentoo" \
  38. --with-packager-version="${PVR}" \
  39. --with-packager-bug-reports="https://bugs.gentoo.org/" \
  40. --program-prefix=${program_prefix} \
  41. $(use_enable nls) \
  42. $(use_with selinux) \
  43. --libexecdir='$(libdir)'/find
  44. }
  45. src_compile() {
  46. # We don't build locate, but the docs want a file in there.
  47. emake -C locate dblocation.texi
  48. default
  49. }