firejail-lts-0.9.38.10.ebuild 734 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. MY_PN=firejail
  6. MY_P="${MY_PN}-${PV}"
  7. DESCRIPTION="Security sandbox for any type of processes; LTS branch"
  8. HOMEPAGE="https://firejail.wordpress.com/"
  9. SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64"
  13. IUSE="+seccomp"
  14. DEPEND="!sys-apps/firejail"
  15. RDEPEND="${DEPEND}"
  16. S="${WORKDIR}/${MY_P}"
  17. src_prepare() {
  18. find -name Makefile.in -exec sed -i -r \
  19. -e '/^\tinstall .*COPYING /d' \
  20. -e '/CFLAGS/s: (-O2|-ggdb) : :g' \
  21. -e '1iCC=@CC@' {} + || die
  22. }
  23. src_configure() {
  24. econf \
  25. --docdir="${EPREFIX}/usr/share/doc/${PF}" \
  26. $(use_enable seccomp)
  27. }