fwcrv-0.1.0.ebuild 610 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="FireWire CSR Config ROM Viewer"
  5. HOMEPAGE="http://www.hugovil.com/en/fwcrv/"
  6. SRC_URI="http://www.hugovil.com/repository/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="x86 ~ppc"
  10. IUSE=""
  11. DEPEND="sys-libs/libraw1394"
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. epatch "${FILESDIR}"/${P}-endian.patch
  16. }
  17. src_compile() {
  18. econf || die "econf failed"
  19. emake || die "emake failed"
  20. }
  21. src_install() {
  22. emake DESTDIR="${D}" install || die
  23. dodoc AUTHORS README src/testdata.txt TODO
  24. }