fwts-15.12.00.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools
  5. DESCRIPTION="Firmware Test Suite"
  6. HOMEPAGE="https://wiki.ubuntu.com/Kernel/Reference/fwts"
  7. SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${PN}_${PV}.orig.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/json-c-0.10-r1
  13. dev-libs/glib:2
  14. dev-libs/libpcre
  15. sys-apps/pciutils
  16. sys-power/iasl
  17. sys-power/pmtools
  18. sys-apps/dmidecode"
  19. DEPEND="${RDEPEND}
  20. sys-devel/libtool"
  21. S=${WORKDIR}
  22. src_prepare(){
  23. sed -i -e 's/-Wall -Werror/-Wall/' configure.ac {,src/,src/lib/src/}Makefile.am || die
  24. sed -i -e 's:/usr/bin/lspci:'$(type -p lspci)':' src/lib/include/fwts_binpaths.h || die
  25. # Fix json-c includes
  26. sed -e 's/^#include <json\//#include <json-c\//g' -i \
  27. configure.ac || die
  28. sed -e 's/^#include <json.h>/#include <json-c\/json.h>/' \
  29. -i src/lib/include/fwts_json.h \
  30. src/utilities/kernelscan.c || die
  31. sed -e 's/-ljson/-ljson-c/'\
  32. -i src/Makefile.am\
  33. src/lib/src/Makefile.am\
  34. src/utilities/Makefile.am || die
  35. eautoreconf
  36. }