gentoo-systemd-integration-4.ebuild 709 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils systemd
  5. DESCRIPTION="systemd integration files for Gentoo"
  6. HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
  7. SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
  11. IUSE=""
  12. RDEPEND=">=sys-apps/systemd-207
  13. !sys-fs/eudev
  14. !sys-fs/udev"
  15. src_configure() {
  16. local myeconfargs=(
  17. "$(systemd_with_unitdir)"
  18. # TODO: solve it better in the eclass
  19. --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
  20. )
  21. autotools-utils_src_configure
  22. }