gentoo-systemd-integration-9999.ebuild 792 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. if [[ ${PV} == 9999 ]]; then
  5. EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
  6. inherit autotools git-r3
  7. else
  8. SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
  9. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  10. fi
  11. inherit systemd
  12. DESCRIPTION="systemd integration files for Gentoo"
  13. HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
  14. LICENSE="BSD"
  15. SLOT="0"
  16. IUSE=""
  17. RDEPEND=">=sys-apps/systemd-207
  18. !sys-fs/eudev
  19. !sys-fs/udev"
  20. DEPEND=">=sys-apps/systemd-207
  21. virtual/pkgconfig"
  22. if [[ ${PV} == 9999 ]]; then
  23. DEPEND+=" sys-devel/systemd-m4"
  24. fi
  25. src_prepare() {
  26. default
  27. [[ ${PV} != 9999 ]] || eautoreconf
  28. }