gsmartcontrol-0.8.7.ebuild 990 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic gnome2-utils
  5. DESCRIPTION="Hard disk drive health inspection tool"
  6. HOMEPAGE="http://gsmartcontrol.sourceforge.net/home/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
  8. LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="test"
  12. COMMON_DEPEND="
  13. dev-cpp/gtkmm:2.4
  14. dev-libs/libpcre:3
  15. sys-apps/smartmontools
  16. "
  17. RDEPEND="${COMMON_DEPEND}
  18. x11-apps/xmessage
  19. "
  20. DEPEND="${COMMON_DEPEND}
  21. virtual/pkgconfig
  22. test? ( dev-util/gtk-builder-convert )
  23. "
  24. DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
  25. src_prepare() {
  26. default
  27. append-cxxflags -std=c++11
  28. }
  29. src_configure() {
  30. econf $(use test tests)
  31. }
  32. src_install() {
  33. default
  34. rm -f "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
  35. }
  36. pkg_preinst() { gnome2_icon_savelist; }
  37. pkg_postinst() { gnome2_icon_cache_update; }
  38. pkg_postrm() { gnome2_icon_cache_update; }