hbaapi-2.2.ebuild 899 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. MY_PN="${PN}_src"
  6. MY_P="${MY_PN}_${PV}"
  7. DESCRIPTION="The Host Bus Adapter API for managing Fibre Channel Host Bus Adapters"
  8. HOMEPAGE="http://hbaapi.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz
  10. mirror://gentoo/${P}.Makefile.gz"
  11. LICENSE="SNIA"
  12. SLOT="0"
  13. KEYWORDS="~ppc ~x86 ~amd64"
  14. IUSE=""
  15. RESTRICT="test"
  16. S="${WORKDIR}/${MY_P}"
  17. src_prepare() {
  18. mv "${WORKDIR}"/${P}.Makefile "${S}"/Makefile
  19. sed -i -e "s/-g -c/${CFLAGS} -c/" \
  20. -e "s/-shared/\0 ${LDFLAGS}/" \
  21. Makefile || die
  22. epatch "${FILESDIR}"/${P}-qa.patch
  23. }
  24. src_compile() {
  25. # not parallel safe!
  26. emake -j1 CC="$(tc-getCC)" all
  27. }
  28. src_install() {
  29. into /usr
  30. dolib.so libHBAAPI.so
  31. dosbin hbaapitest
  32. insinto /etc
  33. doins "${FILESDIR}"/hba.conf
  34. dodoc readme.txt
  35. }