hdparm-9.50.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs flag-o-matic eutils
  5. DESCRIPTION="Utility to change hard drive performance parameters"
  6. HOMEPAGE="https://sourceforge.net/projects/hdparm/"
  7. SRC_URI="mirror://sourceforge/hdparm/${P}.tar.gz"
  8. LICENSE="BSD GPL-2" # GPL-2 only
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
  11. IUSE="static"
  12. src_prepare() {
  13. epatch "${FILESDIR}"/${PN}-9.48-sysmacros.patch #580052
  14. epatch "${FILESDIR}"/${PN}-9.50-build.patch
  15. use static && append-ldflags -static
  16. }
  17. src_configure() {
  18. tc-export CC
  19. export STRIP=:
  20. }
  21. src_install() {
  22. into /
  23. dosbin hdparm contrib/idectl
  24. newinitd "${FILESDIR}"/hdparm-init-8 hdparm
  25. newconfd "${FILESDIR}"/hdparm-conf.d.3 hdparm
  26. doman hdparm.8
  27. dodoc hdparm.lsm Changelog README.acoustic hdparm-sysconfig
  28. docinto wiper
  29. dodoc wiper/{README.txt,wiper.sh}
  30. docompress -x /usr/share/doc/${PF}/wiper/wiper.sh
  31. }