heirloom-tools-070715.ebuild 1020 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit flag-o-matic toolchain-funcs
  5. # slightly broken
  6. RESTRICT="test"
  7. DESCRIPTION="Heirloom toolchest - original Unix tools"
  8. HOMEPAGE="http://heirloom.sourceforge.net/tools.html"
  9. SRC_URI="http://downloads.sourceforge.net/project/heirloom/heirloom/${PV}/heirloom-${PV}.tar.bz2"
  10. LICENSE="CDDL GPL-2 LGPL-2.1 9base ZLIB"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. DEPEND="sys-apps/ed
  15. sys-libs/zlib[static-libs]"
  16. RDEPEND=""
  17. S="${WORKDIR}/heirloom-${PV}"
  18. src_compile() {
  19. append-cppflags -D_GNU_SOURCE
  20. emake -j1 ||die
  21. }
  22. src_install() {
  23. # we don't want to strip here, so use "true" as noop
  24. emake STRIP="true" ROOT="${D}" -j1 install || die
  25. }
  26. pkg_postinst() {
  27. elog "You may want to add /usr/5bin or /usr/ucb to \$PATH"
  28. elog "to enable using the apps of heirloom toolchest by default."
  29. elog "Man pages are installed in /usr/share/man/5man/"
  30. elog "You may need to set \$MANPATH to access them."
  31. }