hwloc-1.6.1.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit multilib versionator
  5. MY_PV=v$(get_version_component_range 1-2)
  6. DESCRIPTION="displays the hardware topology in convenient formats"
  7. HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
  8. SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
  12. IUSE="cairo debug +numa +pci plugins svg static-libs xml X"
  13. RDEPEND="sys-libs/ncurses
  14. cairo? ( x11-libs/cairo[X?,svg?] )
  15. pci? ( sys-apps/pciutils )
  16. plugins? ( sys-devel/libtool )
  17. numa? ( sys-process/numactl )
  18. xml? ( dev-libs/libxml2 )"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig"
  21. DOCS=( AUTHORS NEWS README VERSION )
  22. src_configure() {
  23. export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
  24. econf \
  25. --docdir="${EPREFIX}"/usr/share/doc/${PF} \
  26. $(use_enable cairo) \
  27. $(use_enable debug) \
  28. $(use_enable pci) \
  29. $(use_enable plugins) \
  30. $(use_enable numa libnuma) \
  31. $(use_enable static-libs static) \
  32. $(use_enable xml libxml2) \
  33. $(use_with X x) \
  34. --disable-silent-rules
  35. }
  36. src_install() {
  37. default
  38. if ! use static-libs; then
  39. rm "${D}"/usr/$(get_libdir)/lib${PN}.la
  40. use plugins && rm -f "${D}"/usr/$(get_libdir)/${PN}/*.la
  41. fi
  42. }