ibm-powerpc-utils-papr-1.1.0.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. MY_P="powerpc-utils-papr-${PV}"
  5. DESCRIPTION="This package provides the utilities which are intended for the maintenance of IBM powerpc platforms"
  6. SRC_URI="http://powerpc-utils.ozlabs.org/releases/powerpc-utils-papr-${PV}.tar.gz"
  7. HOMEPAGE="http://powerpc-utils.ozlabs.org/"
  8. S="${WORKDIR}/${MY_P}"
  9. SLOT="0"
  10. LICENSE="IBM"
  11. KEYWORDS="ppc ppc64"
  12. IUSE=""
  13. RDEPEND=">=sys-apps/ibm-powerpc-utils-1.1.0
  14. sys-libs/librtas
  15. virtual/logger"
  16. src_unpack() {
  17. unpack ${A}
  18. epatch "${FILESDIR}"/ibm-powerpc-utils-papr-1.1.0-remove-doc.patch
  19. epatch "${FILESDIR}"/ibm-powerpc-utils-papr-1.1.0-removeinitandvscsis.patch
  20. }
  21. src_install() {
  22. make DESTDIR="${D}" install || die "Compilation failed"
  23. dodoc README COPYRIGHT
  24. #dodir /etc/init.d
  25. #exeinto /etc/init.d
  26. #newexe ${FILESDIR}/ibmvscsis ibmvscsis
  27. }
  28. pkg_postinst() {
  29. #einfo "An initscript for managing virtual scsi servers has "
  30. #einfo "been install into /etc/init.d/ called ibmviscsis. "
  31. #einfo "Before you can use this daemon, you must create a proper "
  32. #einfo "/etc/ibmvscsis.conf file."
  33. einfo "Support for the IBM Virtual SCSI server (virtual disk) "
  34. einfo "is not included in this version of powerpc-utils-papr. "
  35. einfo "When the ibmvscsis function is generally available in "
  36. einfo "the kernel source trees, it will be added back in."
  37. }