idle3-tools-0.9.1.ebuild 500 B

1234567891011121314151617181920212223
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit base toolchain-funcs
  5. DESCRIPTION="Read, Set or disable the idle3 timer of Western Digital drives"
  6. HOMEPAGE="http://idle3-tools.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND="${DEPEND}"
  14. src_compile() {
  15. emake CC="$(tc-getCC)" CFLAGS="-Wall ${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
  16. }