ifplugd-0.28-r10.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
  5. HOMEPAGE="http://0pointer.de/lennart/projects/ifplugd/"
  6. SRC_URI="http://0pointer.de/lennart/projects/ifplugd/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~arm hppa ppc x86"
  10. IUSE="doc selinux"
  11. DEPEND="virtual/pkgconfig
  12. doc? ( www-client/lynx )
  13. >=dev-libs/libdaemon-0.5"
  14. RDEPEND=">=dev-libs/libdaemon-0.5
  15. >=sys-apps/baselayout-1.12
  16. selinux? ( sec-policy/selinux-ifplugd )"
  17. PATCHES=(
  18. "${FILESDIR}/${P}-nlapi.diff"
  19. "${FILESDIR}/${P}-interface.patch"
  20. "${FILESDIR}/${P}-strictalias.patch"
  21. "${FILESDIR}/${P}-noip.patch"
  22. "${FILESDIR}/${P}-musl.patch"
  23. )
  24. DOCS=( doc/README doc/SUPPORTED_DRIVERS )
  25. HTML_DOCS=( doc/README.html doc/style.css )
  26. src_configure() {
  27. econf \
  28. $(use_enable doc lynx) \
  29. --with-initdir=/etc/init.d \
  30. --disable-xmltoman \
  31. --disable-subversion
  32. }
  33. src_install() {
  34. default
  35. # Remove init.d configuration as we no longer use it
  36. rm -rf "${ED}/etc/ifplugd" "${ED}/etc/init.d/${PN}" || die
  37. exeinto "/etc/${PN}"
  38. newexe "${FILESDIR}/${PN}.action" "${PN}.action"
  39. }