install-xattr-0.5-r1.ebuild 950 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
  5. HOMEPAGE="https://dev.gentoo.org/~blueness/install-xattr/"
  6. inherit toolchain-funcs
  7. if [[ ${PV} == "9999" ]] ; then
  8. EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
  9. inherit git-r3
  10. else
  11. SRC_URI="https://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
  12. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
  13. S=${WORKDIR}/${PN}
  14. fi
  15. LICENSE="GPL-3"
  16. SLOT="0"
  17. src_prepare() {
  18. tc-export CC
  19. eapply_user
  20. }
  21. src_compile() {
  22. if [[ ${PV} == "9999" ]] ; then
  23. cd "${WORKDIR}/${P}/misc/${PN}" || die
  24. fi
  25. default
  26. }
  27. src_install() {
  28. if [[ ${PV} == "9999" ]] ; then
  29. cd "${WORKDIR}/${P}/misc/${PN}" || die
  30. fi
  31. DESTDIR=${ED} emake install
  32. }
  33. # We need to fix how tests are done
  34. src_test() {
  35. true
  36. }