inxi-2.3.0_p20160807.ebuild 925 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_COMMIT=c2a22b3e2590d896d4b0a8fd298f505cc1d787f5 #because upstream refuses to tag commits with version numbers
  5. MY_SHORTCOMMIT=${MY_COMMIT:0:7}
  6. DESCRIPTION="Commandline script to print hardware information for irc and administration."
  7. HOMEPAGE="https://github.com/smxi/inxi"
  8. SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~x86"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND=">=app-shells/bash-3.0
  15. sys-apps/pciutils
  16. "
  17. S="${WORKDIR}/smxi-${PN}-${MY_SHORTCOMMIT}"
  18. src_install() {
  19. dobin ${PN}
  20. doman ${PN}.1.gz
  21. }
  22. pkg_postinst() {
  23. einfo "To view a short or full system information."
  24. einfo "inxi -b for short information."
  25. einfo "inxi -F for full information."
  26. einfo "inxi provides seven verbose levels -v1 to -v7."
  27. einfo "inxi -h for help."
  28. }