isapnptools-1.27.ebuild 693 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit eutils
  5. DESCRIPTION="Tools for configuring ISA PnP devices"
  6. HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
  7. SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/hardware/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="-* amd64 x86"
  11. IUSE=""
  12. src_prepare() {
  13. epatch "${FILESDIR}"/${P}-include.patch
  14. }
  15. src_install() {
  16. emake DESTDIR="${D}" install || die
  17. dodir /sbin
  18. mv "${D}"/usr/sbin/isapnp "${D}"/sbin/ || die
  19. dodoc AUTHORS ChangeLog README NEWS
  20. docinto txt
  21. dodoc doc/README* doc/*.txt test/*.txt
  22. dodoc etc/isapnp.*
  23. newinitd "${FILESDIR}"/isapnp.rc isapnp
  24. }