lomoco-1.0-r9.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils multilib toolchain-funcs udev
  5. DESCRIPTION="Lomoco can configure vendor-specific options on Logitech USB mice"
  6. HOMEPAGE="http://www.lomoco.org/"
  7. SRC_URI="http://www.lomoco.org/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 x86"
  11. IUSE=""
  12. RDEPEND="virtual/libusb:0"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. DOCS="AUTHORS ChangeLog NEWS README"
  16. src_prepare() {
  17. cp -f "${FILESDIR}"/lomoco-pm-utils-r1 "${T}" || die
  18. sed -i -e "s|@UDEVDIR@|$(get_udevdir)|" "${T}"/lomoco-pm-utils-r1 || die
  19. epatch \
  20. "${FILESDIR}"/${P}-gentoo-hardware-support.patch \
  21. "${FILESDIR}"/${P}-updated-udev.patch
  22. eautoreconf
  23. }
  24. src_compile() {
  25. emake
  26. emake udev-rules
  27. }
  28. src_install() {
  29. default
  30. insinto "$(get_udevdir)"/rules.d
  31. newins udev/lomoco.rules 40-lomoco.rules
  32. exeinto "$(get_udevdir)"
  33. newexe udev/udev.lomoco lomoco
  34. insinto /etc
  35. doins "${FILESDIR}"/lomoco.conf
  36. exeinto /etc/pm/sleep.d
  37. newexe "${T}"/lomoco-pm-utils-r1 lomoco
  38. }