lsadb-0.1.3.ebuild 655 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="Prints out information on all devices attached to the ADB bus"
  5. HOMEPAGE="http://pbbuttons.berlios.de/projects/lsadb/"
  6. #SRC_URI="mirror://berlios/pub/pbbuttons/${PN}-${PV}.tgz"
  7. SRC_URI="mirror://gentoo/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="-* ~ppc"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND="$DEPEND"
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. epatch "${FILESDIR}/${PN}-makefile.patch"
  18. }
  19. src_compile() {
  20. emake CC="$(tc-getCC)" || die "emake failed"
  21. }
  22. src_install() {
  23. dobin lsadb
  24. doman lsadb.1
  25. dodoc README
  26. }