man-pages-4.10.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GENTOO_PATCH=2
  5. DESCRIPTION="A somewhat comprehensive collection of Linux man pages"
  6. HOMEPAGE="https://www.kernel.org/doc/man-pages/"
  7. SRC_URI="mirror://kernel/linux/docs/man-pages/Archive/${P}.tar.xz
  8. mirror://kernel/linux/docs/man-pages/${P}.tar.xz
  9. mirror://gentoo/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
  10. https://dev.gentoo.org/~cardoe/files/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2"
  11. LICENSE="man-pages GPL-2+ BSD"
  12. SLOT="0"
  13. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
  14. IUSE_L10N=" da de fr it ja nl pl ro ru zh-CN"
  15. IUSE="nls ${IUSE_L10N// / l10n_}"
  16. RESTRICT="binchecks"
  17. # Block packages that used to install colliding man pages #341953 #548900 #612640
  18. RDEPEND="virtual/man
  19. !<sys-apps/keyutils-1.5.9-r3
  20. !<sys-apps/attr-2.4.47-r2
  21. !<dev-libs/libaio-0.3.109-r2"
  22. PDEPEND="nls? (
  23. l10n_da? ( app-i18n/man-pages-da )
  24. l10n_de? ( app-i18n/man-pages-de )
  25. l10n_fr? ( app-i18n/man-pages-fr )
  26. l10n_it? ( app-i18n/man-pages-it )
  27. l10n_ja? ( app-i18n/man-pages-ja )
  28. l10n_nl? ( app-i18n/man-pages-nl )
  29. l10n_pl? ( app-i18n/man-pages-pl )
  30. l10n_ro? ( app-i18n/man-pages-ro )
  31. l10n_ru? ( app-i18n/man-pages-ru )
  32. l10n_zh-CN? ( app-i18n/man-pages-zh_CN )
  33. )
  34. sys-apps/man-pages-posix"
  35. src_configure() { :; }
  36. src_compile() { :; }
  37. src_install() {
  38. emake install prefix="${EPREFIX}/usr" DESTDIR="${D}"
  39. dodoc man-pages-*.Announce README Changes*
  40. # Override with Gentoo specific or additional Gentoo pages
  41. cd "${WORKDIR}"/man-pages-gentoo
  42. doman */*
  43. dodoc README.Gentoo
  44. }