memtester-4.2.2.ebuild 710 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit toolchain-funcs
  5. DESCRIPTION="userspace utility for testing the memory subsystem for faults"
  6. HOMEPAGE="http://pyropus.ca/software/memtester/"
  7. SRC_URI="http://pyropus.ca/software/memtester/${P}.tar.gz
  8. http://pyropus.ca/software/memtester/old-versions/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~arm ~ia64 ~mips ppc ppc64 ~sparc x86"
  12. IUSE=""
  13. src_prepare() {
  14. echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc
  15. echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld
  16. }
  17. src_install() {
  18. dosbin memtester
  19. doman memtester.8
  20. dodoc BUGS CHANGELOG README README.tests
  21. }