modutils-2.4.27-r1.ebuild 926 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils
  5. DESCRIPTION="Standard kernel module utilities for linux-2.4 and older"
  6. HOMEPAGE="https://www.kernel.org/pub/linux/utils/kernel/modutils/"
  7. SRC_URI="mirror://kernel/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
  11. IUSE=""
  12. RDEPEND="!sys-apps/module-init-tools
  13. !sys-apps/kmod"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-alias.patch
  16. epatch "${FILESDIR}"/${P}-gcc.patch
  17. epatch "${FILESDIR}"/${P}-flex.patch
  18. epatch "${FILESDIR}"/${P}-no-nested-function.patch
  19. }
  20. src_configure() {
  21. econf \
  22. --prefix=/ \
  23. --disable-strip \
  24. --enable-insmod-static \
  25. --disable-zlib
  26. }
  27. src_install() {
  28. einstall prefix="${D}"
  29. rm -r "${ED}"/usr/share/man/man2 || die
  30. dodoc CREDITS ChangeLog NEWS README TODO
  31. }